VL wizard not recognizing my midi USB interface

Issues, bugs, suggestions related to the VL-Wizard Settings
Post Reply
saxninja
Posts: 11
Joined: Wed Apr 13, 2016 12:01 pm

VL wizard not recognizing my midi USB interface

Post by saxninja » Wed Sep 28, 2016 1:55 am

Hi - after the initial software release my midi connection was working very reliably. Recently I hadn't been using my pc setup for awhile due to heavy gigging. Now the last few times I've hooked it up my USB midi box (midisport 2x2) doesn't show up in the settings. I've attached a picture of my device manager screen showing the midisport under audio controllers. So the computer recognizes it. I'm running Win 7 64bit sp1.

Any ideas what might be causing this? I've tried connecting things in different orders and it doesn't seem to help. It suddenly worked (showed up in settings) the other day but I have no idea what I may have done to get it to work. Clicking on the midi port refresh button doesn't seem to do anything.

Regards,
Bob
Attachments
midi 1.jpg
midi 1.jpg (91.76 KiB) Viewed 2953 times

User avatar
VL-Wizard
Posts: 108
Joined: Fri Mar 04, 2016 2:24 pm
Location: Belgium
Contact:

Re: VL wizard not recognizing my midi USB interface

Post by VL-Wizard » Wed Sep 28, 2016 2:20 pm

The VL-Wizard does NOT dynamically refresh the list of available Midi controllers. You force a rescan of the available midi-interfaces by pressing the little orange ® button.
It is recommended to do this each time when you changed the midi-interfaces (adding, removing, renaming etc.)

In your case the refresh does not seem to detect the changes of midi-interfaces. Please try following;
- Restart Windows while keeping your USB midi-interfaces plugged in. This will ensure correct initialization of midi-usb interfaces.
- Disable the USB device sleep mode (see Windows power saving settings).
- Ensure the USB interface receives enough power, avoid connection to an USB hub

I recently received an upgrade of the development platform for the VL-Wizard software. This development platform includes improvements related to midi-ports. I plan to release a new version of the VL-Wizard around mid-october.

hope this helps
Rudy

saxninja
Posts: 11
Joined: Wed Apr 13, 2016 12:01 pm

Re: VL wizard not recognizing my midi USB interface

Post by saxninja » Thu Sep 29, 2016 3:17 am

Thanks Rudy. 1 for 1 so far with restarting my computer with the midisport connected. By the way - I was playing around with the midi looper the other day...really appreciate this feature! Much nicer to hear back what it sounds like than to just listen while playing. It allows for a more critical review of the sounds.

User avatar
VL-Wizard
Posts: 108
Joined: Fri Mar 04, 2016 2:24 pm
Location: Belgium
Contact:

Re: VL wizard not recognizing my midi USB interface

Post by VL-Wizard » Thu Sep 29, 2016 4:29 am

Yes, the midi-looper (phrase widget) is a handy tool for auditioning your sounds and even tweak while listening to the changes.
You can also change the octave range it for the playback. This is how;
- stop the playback
- click on the mini keyboard under the status leds (see main screen)
- select the octave shift value
- start the playback

The version 5.0.4c will also contain a possibility to adjust the breath level of the midi playback.

Hereby some midi phrases. (VL70m demo songs)
MidiPhrases.zip
(136.69 KiB) Downloaded 167 times

Post Reply