Installing Gotek Floppy Emulator in VL1m

Post here topics related to VL hardware.
Post Reply [phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable
Posts: 14
Joined: Wed Nov 30, 2016 7:43 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable

Installing Gotek Floppy Emulator in VL1m

Post by mmtuk » Thu Mar 02, 2017 9:29 am

Sorry, but rather a long account of my experience replacing the floppy drive in my VL1m..........

*** (Copy of details posted in the HxC2001 forum) ***

1st post!

I recently bought 2 Gotek floppy emulators (3 digit version), 1 for my EX5r the other for my VL1m. I thought I'd tackle the VL1m 1st because the floppy drive stepper motor appears to be dead.

Before 'upgrading' one of the Goteks I'd got it to work almost okay without any modification. I say almost okay because the best scenario during use was to power up the VL1m and select the required floppy number before asking the VL1m to access a 'floppy'. This worked faultlessly except that It was not possible to select another floppy without powering down and repeating the former process.

I tried various methods of switching pins 2 and 34 to see if that helped, but nothing did, including as many different jumper settings that I could conceive.

I then successfully reflashed one of the Goteks. I'm now actually worse off because the VL1m can't see any of the images on the USB stick. I've got the right configuration file on the USB stick and followed the naming convention for the Index mode. I've tried both FAT and FAT32 formats of the USB stick and that doesn't change things. With a FAT format the HXC firmware doesn't seem to boot properly, with just 'hxc' displayed. FAT is the native format for the VL1m. With a FAT32 format, the Gotek fully initialises and images are selectable, but the VL1m can't see them at all.

I blindly tinkered with a few configuration settings in the hxc software, and transferring the saved file(s) to the USB stick but nothing improved. It might be worth pointing out that there is a 34 way to 26 way adapter on the back of the Gotek to correctly interface with the VL1m, but this is a purely passive adapter and makes no change to the data traffic. In any event, it works fine with a native Gotek excepting the above mentioned problem.

I'm assuming that with the vast array of configuration setting within the hxc software that I will be able to get it all to work satisfactorily, I just need some help in narrowing down which options I play with.

Thanks in advance for any help offered.

Update: by removing the Drive select jumper (neither 0 or 1 selected) and with a jumper installed on 'MO' then the drive behaves as per native Gotek mode (i.e. - before hxc upgrade). I can access only the first selected floppy image after powering up the VL1m.

Further update.......

I contacted the supplier of the 34/26 pin adapter who sold it to me as being suitable for a Yamaha Vl1/VL1m/VL7, giving him the details of my problem in my first post. He made no reference to the HXC conversion but instead directed me to: ... ketron.exe

His instructions were (English not native language):


1.Install the program as admin on PC.
2.Program (Virtual Floppy Format) run.
3.Select a Flash Disk Select (USB stick) min 8Gb.
4.Number of partition:1000
5.Floppy Partition Size 1,44 MB filter.
6.Start format.

After installation, the program Virtual Floppy Explorer start, select virtuele floppy and copy files.
Rest is self-explanatory.

Please only emulator: from Gotek SFR1M44-U100K use.
Emulator jumper settings: 1Jumper must be set to S1.And the others have to get out.


He made no mention of the HXC Gotek so I assumed that the instructions referred to the unmodified Gotek. I followed the instructions and ended up with an 8GB USB stick with 1000 partitions (floppy images).

I copied some files to the first half dozen imagess (not 000 which had something in it) and without delay plugged it into the VL1m. Both the Gotek and the VL1m seemed happy with each other, but still no recognition of disk changes. I did however manage to get further towards my goal.

I noticed that if I used the buttons to change disks, then removed the USB stick and replaced it, it kept the selected disk number in the display and I could then read the contents of the 'new' disk (we won't go down the path of 'writing' yet - 1 thing at a time!). This worked most of the time but not 100%, maybe issues with speed of my actions, however it is nearly as I wanted when I first embarked on the Gotek adventure.

Rather than plugging in and out the USB stick I wondered if I could cut one of the tracks to the USB socket (5v?) and insert a momentary disconnect switch in place. This would save hugely on wear and tear! If anybody has firm knowledge they wish to impart it would be greatly appreciated.

Having got this far I can only assume that it's software settings with regard to the HXC Gotek I have as the hardware is clearly capable of fulfilling the required tasks.

I still want the HXC Gotek to work, and am hoping that someone will help me overcome the problems with it.

Yet another update.....

After reading another item on this forum regarding a Korg Trinity and a Gotek I decided to give some of Jeffs suggestions a try.

What finally solved my problems was the following:

My HxC Gotek has a jumper on MO, a jumper on S1 and I've shorted pin 12 of the 34way connector to ground (vcc).

Change any of the above and the result is a fail.

Everything now works 100%, reads, writes, disk changes - Eureka!

Perseverance and a great forum wins the day!

A lingering problem is that the green light of the Gotek is always on and the LED on my USB stick continually flashes. Can anybody let me know if that is likely to cause a long term problem or failure with any components?

Yet more....

I spoke too soon......

The HxC Gotek is saving files of the correct size, but the file names given using the VL1m at the time of writing are not the names or suffix (file type) that subsequently appear on the USB stick. I don't want to risk corrupting my VL1m by attempting to reload these files and find out what they actually contain.

This phenomenon does not occur at all with the unmodified Gotek in conjunction with the Ketron software.

There are clearly some strange things going on with the Gotek/HxC setup - does anybody want to rise to the challenge?

Yet another further update......

As stated before my last post, everything appears to be working okay with the exception of the file name issue mentioned in my last post. There is however, a simple fix........

If files (patches etc.) are copied to a new floppy image file using the HxC software they are usable & appear correctly on the VL1m menus. BUT! - any subsequent writes to that floppy image done on the VL1m result in corrupt file names and maybe data (not dared to load!). This only affects the VL1m written files, not the ones originally copied using the HxC software.

I can't explain why (maybe Jeff has an idea?), but if I write a small file to the floppy image from the VL1m first, no subsequent corruption of any read/writes occurs whether done using HxC software or the VL1m.

In use this doesn't present a problem because I create 1 image in the HxC software, write a small file to it on the VL1m then back on the PC use a simple batch file to replicate and rename the floppy image 500 times.

Having used the USB stick for many hours without problem I can say it works 100%.

I don't understand the file issue nor do I understand why the USB stick flashes at a rate of about 2.5 times per second - perhaps somebody will enlighten me.

The lid is firmly back on my VL1m now!

Posts: 14
Joined: Wed Nov 30, 2016 7:43 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable

Re: Installing Gotek Floppy Emulator in VL1m

Post by mmtuk » Thu Mar 02, 2017 10:01 am

Just for those who don't know........

The HxC Floppy Emulator is another device that is incredibly well specified and supported, that is extremely flexible, configurable, and has a good reputation. However, it is a lot more expensive than the cheap Gotek emulators.

See -

HxC have available a firmware upgrade for the Goteks that for some hosts (computers, samplers, keyboards etc.) makes them work better than the native Gotek firmware. Indeed, the software supplied with the Goteks is a cobbled together collection of utilities that may or may not work at all. Not the case with the HxC software/firmware which works very well and is supported by a huge community of forum users across a plethora of hardware.

I bought the HxC firmware (10 euros I think) and the upgrade requires you to obtain a USB/TTL serial device (just a few pounds/euros) to program the Gotek. The process is quite straightforward, fortunately I'd used the same process to reprogram a bug ridden Seagate hard disks firmware many years ago and still had the USB device. There is a lesser known way of doing a firmware upgrade with a USB A to A cable (don't know if it works with the HxC firmware installion routine), I can post details if anybody needs the info and wants to have a go.

Post Reply
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable